Why is the Classic Editor plugin required with Link in Profile?

The Link in Profile plugin adds a new page template where you can simply fill out your options in the page editor and the plugin will handle the rest. While the new block editor introduced in WordPress v5.0 and higher came with the ability for developers to create block templates, they don’t yet work with specific page templates. In order to make this plugin compatible with WordPress’ new block editor, it would have required our customers to layout the page themselves with custom blocks we created. Definitely not as user-friendly!

We’ve opted to require the Classic Editor plugin for the time being, giving our customers a more user-friendly experience. As WordPress and the new block editor environment evolve, we are committed to updating this plugin with block editor compatibility, as soon as block templates can be registered to specific page templates. In the future, this will provide a similar experience as the existing page editor, within the new WordPress interface.  While this feature does appear to be planned for future WordPress updates, no date has been announced at this time. We will continue to monitor WordPress for updates to make this plugin compatible with the block editor system.